How to resolve the PayPal Security error.

When you have integrate your Payment gateway to PAyPAl, some times it will return 10002 – Security error – Security header is not valid.

In this knowledgebase we have shared some solution to rectify this error.

When you have met this issue,  the message indicates that your API credentials aren’t being accepted by PayPal.

To fix this issue :

  1. You have your PayPal module configured to “Sandbox” but have not used Sandbox API credentials. So, kindly enter your correct Sandbox API.
  2. You have your PayPal module configured to “Live” but have not used Live API credentials.So, kindly enter your correct LIVE API.
  3. You have mis-typed one or more API credentials entries, including but not limited to leaving trailing spaces.
  4. You have deleted and/or recreated new API credentials in your PayPal account but have not copied those new credentials back to your PayPal settings.

Rate This Article

(4 out of 10 people found this article helpful)

Leave A Comment?

This site uses Akismet to reduce spam. Learn how your comment data is processed.